You're viewing the documentation of an older Simple Commerce version. Consider upgrading to the latest for new features and bug fixes.

Requirements

Simple Commerce has a few requiements:

While not a requirement, we recommend you have an SSL certificate for your production site.

Standard Install

We recommend installing Simple Commerce via the command line instead of through the Statamic Control Panel.

1. Install Simple Commerce with Composer

composer require doublethreedigital/simple-commerce

2. Run php please sc:install - it'll publish the Simple Commerce default blueprints, configuration file and will setup collections and taxonomies.

3. That's it installed. Really simple.

Quick Start

If you'd prefer to get started with some boilerplate views and Simple Commerce already installed, you should checkout our the Simple Commerce Starter Kit.

Last updated 1 month ago Improve this page on GitHub!