You're viewing the documentation of an older Simple Commerce version. Consider upgrading to the latest for new features and bug fixes.

Requirements

Simple Commerce has a couple pre-requisites. You'll need all of these installed before you can get started.

  • PHP 7.4 or PHP 8.0
  • Statamic 3 - v3.0 and v3.1 both work fine
  • The php-intl extension for PHP - it's used for currency formatting

While not strictly required, it's highly recommend you use SSL on your production site for security.

Standard Install

While you can install Simple Commerce via the Control Panel, I'd recomend installing via Composer instead.

1. Install Simple Commerce with Composer

composer require doublethreedigital/simple-commerce

2. Run php please sc:install - it'll publish the Simple Commerce default blueprints, configuration file and will setup collections and taxonomies.

3. That's it installed. Really simple.

Quick Start

If you'd prefer to get started with some boilerplate views and Simple Commerce already installed, you should checkout our the Simple Commerce Starter Kit.

Last updated 1 month ago Improve this page on GitHub!